Patch urgenti per Flash Player e Photoshop

Adobe ha corretto alcune vulnerabilitÓ di sicurezza in Flash Player e Photoshop CS2/CS3 che potrebbero essere sfruttate da un malintenzionato per eseguire codice dannoso

San Jose (USA) - Adobe ha rilasciato versioni aggiornate di Flash Player e Photoshop CS2/CS3 che correggono alcune vulnerabilità di sicurezza potenzialmente gravi.

Flash Player 9.x contiene un errore nella validazione dell'input che potrebbe permettere ad un aggressore di eseguire del codice a propria scelta, mentre Flash Player 8.x è interessato da un bug nella validazione dell'HTTP Referrer che potrebbe aiutare i cracker ad effettuare attacchi di tipo cross-site scripting. Un altro problema di sicurezza riguarda Flash Player 7.x per Opera e Konqueror sulle piattaforme Linux e Solaris, ma su questo falla Adobe non ha fornito alcuna informazione.

Adobe raccomanda ai propri utenti di passare all'ultima versione di Flash, la 9.0.47.0 (9.0.48.0 nel caso di Linux), ma fornisce delle patch anche per le altre release del programma. L'advisory ufficiale si trova qui.
Gli update di sicurezza a Photoshop CS2 e CS3 risolvono invece le vulnerabilità pubblicate alla fine di aprile da un ricercatore di sicurezza noto come Marsu. Le debolezze sono causate da una non corretta gestione dei file in formato BMP, DIB, RLE e PNG, che se malformati possono causare l'esecuzione di codice. Le patch, che Adobe raccomanda di installare appena possibile, possono essere scaricate dai link contenuti in questo advisory.
2 Commenti alla Notizia Patch urgenti per Flash Player e Photoshop
Ordina