Windows Vista, l'attivazione fa crack

di G. Fleres - A dispetto delle nuove e più sofisticate misure di sicurezza adottate da Microsoft con Windows Vista, i cracker hanno già scoperto un modo per aggirare la procedura di attivazione delle versioni corporate

Roma - A meno di una settimana di distanza dal lancio commerciale delle edizioni aziendali di Windows Vista, i cracker hanno già scovato un modo per bypassare la procedura d'attivazione del nuovo sistema operativo. Il bypass fa leva su alcune peculiarità del meccanismo di attivazione che accompagna le edizioni di Vista, la Business e l'Enterprise, vendute con licenze a volume.

Per agevolare il deployment del nuovo Windows all'interno delle aziende di medie e grandi dimensioni, Microsoft ha studiato un meccanismo, denominato Volume Activation (VA), che permette di attivare più copie di Windows contemporaneamente.

La VA di prima generazione, utilizzata in Windows XP/2003 ed Office 2003/2007, permette di evitare qualsiasi forma di attivazione tramite l'utilizzo di una speciale product key (chiave di registrazione) corporate: questa chiave viene fornita solo a chi acquista licenze a volume, ma in questi anni sono molte quelle divenute di pubblico dominio e utilizzate per attivare copie pirata di Windows od Office.
Per risolvere - o per lo meno mitigare - questo problema, Microsoft ha associato a Windows Vista una nuova e più complessa procedura VA che prevede due diverse modalità di funzionamento: Multiple Activation Keys (MAK) e Key Management Service (KMS).

La prima, MAK, consente di attivare un singolo computer o più gruppi di computer (fino ad un massimo di 25 licenze) collegandoli direttamente con i server Microsoft o effettuando la procedura via Internet o telefono. Le product key fornite con questa modalità possono essere utilizzate per un numero limitato di attivazioni, terminate le quali è necessario contattare il Microsoft Activation Center. L'attivazione via Internet può avvenire in due modi:
- Proxy Activation: più computer sono attivati contemporaneamente utilizzando la stessa connessione con i server Microsoft;
- Indipendent Activation: ogni computer si collega e si attiva separatamente con i server Microsoft.

La seconda modalità di attivazione, KMS, prevede invece che l'attivazione dei client con Windows Vista Business o Enterprise avvenga direttamente all'interno dell'azienda: questo è possibile installando un apposito server fornito da Microsoft. I computer attivati attraverso KMS devono essere riattivati dal server locale almeno ogni sei mesi. In base alle politiche di licenza stabilite da Microsoft, per usare KMS bisogna possedere almeno 25 licenze di Windows Vista.

Attualmente, il software per gestire le attivazioni KMS gira soltanto su Windows Vista o su Windows Server Longhorn. In futuro, stando alle dichiarazioni di Microsoft, sarà disponibile anche per Windows Server 2003.

Il metodo messo a punto dai cracker per bypassare l'attivazione delle versioni aziendali di Vista si basa proprio sul funzionamento di KMS: l'idea è di attivare le versioni Business e Enterprise di Windows Vista per mezzo di server "non autorizzati": tali server possono essere esterni alla propria rete, e magari siti in "paradisi dell'illegalità", oppure integrati in immagini piratate di Vista o di Longhorn. Va notato che in entrambi i casi i client di Vista vengono attivati indipendentemente dalla product key utilizzata, purché questa sia abbinata ad una licenza a volume.

Per l'attivazione tramite un server esterno, è sufficiente svolgere qualche ricerca nell'underground di Internet per trovare l'indirizzo di un server pirata. Successivamente si deve aprire il prompt dei comandi in modalità Administrator (ovvero lanciarlo con l'opzione run as admin) e digitare i comandi standard utilizzati per la normale procedura di attivazione KMS.

Per attivare Vista direttamente in locale, in Rete circola un'immagine per VMware che contiene il server KMS. Dopo aver lanciato questa immagine con VMPlayer, basterà indicare come indirizzo del server con cui attivare Vista quello della macchina virtuale di WMPlayer.

Va ricordato che KMS richiede la riattivazione del client ogni 180 giorni e che, in entrambi i casi, è necessario disporre di una product key corporate valida. Inutile ricordare, infine, che utilizzare un server di attivazione o una product key non autorizzati da Microsoft è illegale, e chi lo fa potrebbe incorrere in tutte le sanzioni del caso.

Update (ore 12,45) - Su questo post apparso sul Josh's Windows Weblog è stato pubblicato un commento ufficiale di Microsoft sui recenti crack di Windows Vista, incluso il bypass dell'attivazione. Nel frattempo si sta registrando proprio in queste ore una rapida crescita del numero di server KMS illegali registrati in Cina (cn).

Giovanni Fleres
378 Commenti alla Notizia Windows Vista, l'attivazione fa crack
Ordina
  • WINDOWS VISTA ATTIVAZIONE AUTOMATICA:

    Dimenticare tutti i complicazione di dover modificare le date e la configurazione del tuo PC.
    Con solo 3 MB, il programma si attiva automaticamente Windows Vista.
    Non devi fare nulla.

    SCARIACA QUI
    http://rapidshare.com/files/113920598/Vista_Ativac...
    http://rapidshare.com/files/113921026/Vista_Ativac...
    http://rapidshare.com/files/113921445/Vista_Ativac...

    TENUTO CONTO DI VISTA SUL IMMAGINE QUI
    http://rapidshare.com/files/87332465/Windows_Vista...
    non+autenticato
  • perche' i programmi commerciali esistono, si installano in poco tempo, piutosto lo copiano....

    Suse 10, Installare cinelerra

    Yast, non lo conosce, non e' presente nell'elenco.

    Passiamo la palla a Google.

    proviamo

    http://heroinewarrior.com/cinelerra.php3

    daccordo che e' per suse 10.1 io uso la 10.0, ma magari funziona ugualmente, spero non voglia qualcosa di inserito solo in suse 10.1.

    Scarico l'PRM ( 18mb )e lo apro con yast.

    conflitti irrisolti
    mjpegtools >= 1.6.3
    liba52.so.0
    libfaac.so.0
    libfaad.so.0
    libiec5183.so.0
    libmjpegutils-1-8.so.0
    libmp4v2.so.0
    libtheora.so.0
    libx264.so.54

    annullo l'oprazione, riparto da google.

    apro il sito ufficiale e scarico i sorgenti ( 30mb ), nel frattempo continuo le ricerche su google.

    scarico e provo a scompattare il file....

    errore

    tar:/....... è una cartella avrebbe dovuto essere un file

    riproco a scompattarlo...

    troppo lento, dopo minuti e' ancora allo 0% della scompattazione.......

    passo a kino......

    purtroppo nel repository ho una vecchia versione 0.7, nel loro sito c'e' la 0.9.3

    scarico la 0.9.3

    faccio partire la compilazione....

    Package libraw1394 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libraw1394.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libraw1394' found

    ...

    avc1394.h not found, install libavc1394-devel

    ......

    configure: error: libiec61883 is the new, preferred Linux 1394 streaming
                    interface; others are deprecated. If you only support dv1394,
                    then you must explicitly specify it using --with-dv1394.


    e che vuol dire?

    non+autenticato

  • - Scritto da:

    > e che vuol dire?

    http://www.inglese.it/
    non+autenticato

  • - Scritto da:
    >
    > - Scritto da:
    >
    > > e che vuol dire?
    >
    > http://www.inglese.it/

    tu invece vai qui:
    http://www.facciofintadinoncapire.it
    non+autenticato

  • - Scritto da:
    > perche' i programmi commerciali esistono, si
    > installano in poco tempo, piutosto lo
    > copiano....
    >
    > Suse 10, Installare cinelerra

    E secondo te cinelerra è una roba da niubbo come te?

    Cinelerra è uno strumento altamente professionale applicazioni che costano fior di soldoni fanno molto meno di quello che fa cinelerra e se le vuoi installare ti tocca di chiamare uno specialista/professionista.
    Cosa ti fa pensare che invece per cinelerra questo sia diverso?


    >
    > Yast, non lo conosce, non e' presente nell'elenco.

    L'elenco lo puoi modificare (ed è anche facile farlo) in alternativa hai apt e altro...

    >
    > Passiamo la palla a Google.
    >
    > proviamo
    >
    > http://heroinewarrior.com/cinelerra.php3
    >
    > daccordo che e' per suse 10.1 io uso la 10.0, ma
    > magari funziona ugualmente, spero non voglia
    > qualcosa di inserito solo in suse
    > 10.1.

    In altre parole sai già che non funziona (come binario) essendo compilato per una versione diversa con librerie diverse!
    Hai mai provato a far girare su win 98 un exploder 7 (adesempio) ?....

    In ogni caso se sei un espertone (non dimenticare che hai bisogno di cinelerra) non ti sarebbe difficile compilarlo per il tuo sistema...

    Oppure fare un upgrate GRATIS a SUSE 10.1

    >
    > Scarico l'PRM ( 18mb )e lo apro con yast.
    >
    > conflitti irrisolti
    > mjpegtools >= 1.6.3
    > liba52.so.0
    > libfaac.so.0
    > libfaad.so.0
    > libiec5183.so.0
    > libmjpegutils-1-8.so.0
    > libmp4v2.so.0
    > libtheora.so.0
    > libx264.so.54
    >

    Infatti ti dice con chiarezza di quali librerie e tools haai bisogno o devi sostituire in win questo te lo puoi sognare!

    > annullo l'oprazione, riparto da google.

    Ti se scordato di dire "senza leggere e capirci nulla della applicazione che voglio installare"....

    >
    > apro il sito ufficiale e scarico i sorgenti (
    > 30mb ), nel frattempo continuo le ricerche su
    > google.
    >
    > scarico e provo a scompattare il file....
    >
    > errore
    >
    > tar:/....... è una cartella avrebbe dovuto essere
    > un
    > file
    >
    > riproco a scompattarlo...
    >
    > troppo lento, dopo minuti e' ancora allo 0% della
    > scompattazione.......

    Non sai neppure "scompattare" un file tar =1 clikc da gui o un semplice comando da prompt e vuoi usare cinelerra???
    Ma per favoreee!

    >
    > passo a kino......

    che è prorio la stessa cosa di cinelerra vero?

    >
    > purtroppo nel repository ho una vecchia versione
    > 0.7, nel loro sito c'e' la
    > 0.9.3
    >

    Che ci sia un motivo?... conosci la differenza tra le 2 versioni?... mah?

    > scarico la 0.9.3
    >
    > faccio partire la compilazione....
    >
    > Package libraw1394 was not found in the
    > pkg-config search
    > path.
    > Perhaps you should add the directory containing
    > `libraw1394.pc'
    > to the PKG_CONFIG_PATH environment variable
    > No package 'libraw1394' found
    >
    > ...
    >
    > avc1394.h not found, install libavc1394-devel
    >
    > ......
    >
    > configure: error: libiec61883 is the new,
    > preferred Linux 1394
    > streaming
    >                 interface; others are deprecated.
    > If you only support
    > dv1394,
    >                 then you must explicitly specify
    > it using
    > --with-dv1394.
    >
    >
    > e che vuol dire?

    te lo scrive pure!
    Ma leggere prorio non ti hanno insegnato?

    Certo un bel BSOD è mooolto più chiaro!
    A bocca apertaA bocca aperta
    non+autenticato

  • > In altre parole sai già che non funziona (come
    > binario) essendo compilato per una versione
    > diversa con librerie
    > diverse!
    > Hai mai provato a far girare su win 98 un
    > exploder 7 (adesempio)
    > ?....
    >

    Suse 10 e' vecchio di 6 mesi e gia' trovare programmi......
    Win98 e' vecchio di 9 anni, vuoi mettere e comunqe programmi per quel SO ce ne sono ancora molti.....

    >
    > Oppure fare un upgrate GRATIS a SUSE 10.1

    Ogni 6 mesi cambiare OS.......


    > tools haai bisogno o devi sostituire in win
    > questo te lo puoi
    > sognare!

    In windows questo dipende dal programma non dal SO, come ben ricordi tu, linstallazione non la fa il SO.......

    >
    > >
    > > passo a kino......
    >
    > che è prorio la stessa cosa di cinelerra vero?

    e chi lo ha detto, pero' sono i due piu' famosi....


    > > configure: error: libiec61883 is the new,
    > > preferred Linux 1394
    > > streaming
    > >                 interface; others are
    > deprecated.
    > > If you only support
    > > dv1394,
    > >                 then you must explicitly specify
    > > it using
    > > --with-dv1394.
    > >
    > >
    > > e che vuol dire?
    >
    > te lo scrive pure!
    > Ma leggere prorio non ti hanno insegnato?

    visto che sei l'inteligente di turno e io non lo capisco, me lo spieghi? grazie.
    non+autenticato

  • - Scritto da:

    > > Oppure fare un upgrate GRATIS a SUSE 10.1
    >
    > Ogni 6 mesi cambiare OS.......

    Update, questo sconosciuto

    > > te lo scrive pure!
    > > Ma leggere prorio non ti hanno insegnato?
    >
    > visto che sei l'inteligente di turno e io non lo
    > capisco, me lo spieghi?

    Configurazione: Errore: libiec61883 è la nuova preferita interfaccia di streaming 1394 di Linux; altre sono deprecate.
    Se supporti solo dv1394, allora devi esplicitamente specificarlo usando --with-dv1394
    non+autenticato

  • - Scritto da:
    >
    > - Scritto da:
    >
    > > > Oppure fare un upgrate GRATIS a SUSE 10.1
    > >
    > > Ogni 6 mesi cambiare OS.......
    >
    > Update, questo sconosciuto

    se e' come l'update di mandriva, meglio perderlo..... ( leggi i NG e scoprirai nuove incompatibilita' ).

    > Configurazione: Errore: libiec61883 è la nuova
    > preferita interfaccia di streaming 1394 di Linux;
    > altre sono
    > deprecate.
    > Se supporti solo dv1394, allora devi
    > esplicitamente specificarlo usando
    > --with-dv1394


    teoricamente lo stavo compilando, cosa c'entra questo in fase di compilazione?
    non+autenticato

  • - Scritto da:

    > > > Ogni 6 mesi cambiare OS.......
    > >
    > > Update, questo sconosciuto
    >
    > se e' come l'update di mandriva, meglio
    > perderlo..... ( leggi i NG e scoprirai nuove
    > incompatibilita'
    > ).

    suse != mandrivia

    > > Configurazione: Errore: libiec61883 è la nuova
    > > preferita interfaccia di streaming 1394 di
    > Linux;
    > > altre sono
    > > deprecate.
    > > Se supporti solo dv1394, allora devi
    > > esplicitamente specificarlo usando
    > > --with-dv1394
    >
    >
    > teoricamente lo stavo compilando, cosa c'entra
    > questo in fase di
    > compilazione?

    evidentemente c'entra: se non trova la libreria nuova ti informa che devi compilare con il supporto di quella obsoleta (--with-dv1394)
    non+autenticato

  • - Scritto da:
    >
    > - Scritto da:
    > > perche' i programmi commerciali esistono, si
    > > installano in poco tempo, piutosto lo
    > > copiano....
    > >
    > > Suse 10, Installare cinelerra
    >
    > E secondo te cinelerra è una roba da niubbo come
    > te?
    >
    > Cinelerra è uno strumento altamente professionale


    ma per favore, lo usano al massimo 4 sfigati...
    quello del broadcasting è un mondo serio, dove le workstation costano un occhio e devono lavorare altro software *free*

    La torta se la spartiscono solo AVID e Apple con FinalCut.

    Le macchine Linux in questo campo non fanno mai post-produzione sono rilegate solo al 3d e al compositing e mai con software *free* (a parte Linux stesso) ma sempre con soluzioni commerciali o sviluppate internamente.
    non+autenticato
  • FinalCut ?!!! Rotola dal ridereRotola dal ridereRotola dal ridereRotola dal ridereRotola dal ridereRotola dal ridere
    non+autenticato

  • - Scritto da:
    > FinalCut ?!!!
    > Rotola dal ridereRotola dal ridereRotola dal ridereRotola dal ridereRotola dal ridereRotola dal ridere

    Nascondere la testa sotto la sabbia non farà diventare FinalCut meno usato, visto che negli ultimi anni è passato ad avere circa il 40% dei broadcaster e una parcentuale molto maggiore tra i freelance.

    Tutto questo te lo dico dato che lo vedo tutti i giorni nel mio ambiente di lavoro ed è confermato da eminenti ricerche..

    vuoi che tiro fuori i link?
    non+autenticato
  • Fosse l'unica cosa nel sw windows che "fa crack"...
    Purtroppo i crack sono ben altri
    E a noi tocca pure il danno aggiuntivo di zombie botnet e traffico che paghiamo tutti!

    Bisognerebbe maggiorare il costo di chi si connette alle rete con un computer con installata roba di M$ alla rete... magari in questo modo si riequilibra un pochino la bilancia...
    non+autenticato

  • > i cracker hanno già scoperto un modo
    > per aggirare la procedura di attivazione
    > delle versioni corporate


    AH AH AH AHA AH AH AH AHA AH AHA AH AH AH AHA AH AH AH AH AH AH AHA AH AHA AH AH AHA AH AHA AH AHA AH AH AH AH AHA AH AH AH AH AHA AH AHA AHA AHA AH AH AH AHA AH AHA AH AH AH AHA AH AHA AH AHA !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    ....alla faccia della super-sicurezza, del trusted computing e cavolate del genere..

    La realta' e' una e una sola: tutto cio' che viene realizzato da essere umani puo' essere modificato e smantellato da altri esseri umani.

    niente di piu' semplice.



    non+autenticato
CONTINUA A LEGGERE I COMMENTI
1 | 2 | 3 | 4 | 5 | Successiva
(pagina 1/5 - 21 discussioni)