Alessandro Del Rosso

Thunderbird 3.1 è in beta

La prima beta di Thunderbird 3.1 promette di migliorare la migrazione dalla release 2 e di risolvere tanti piccoli problemi di gioventù

Roma - Mozilla Messaging ha avviato il beta testing della prossima major release di Thunderbird, la 3.1 (nome in codice Lanikai), un software che tester, sviluppatori e semplici curiosi possono scaricare da qui.

"Questa release non rappresenta il prodotto finale", avvisano le note di rilascio. "Alcune delle funzionalità qui elencate sono altamente sperimentali e molto probabilmente subiranno dei cambiamenti prima della versione finale. Questa release potrebbe arrivare con crash e bug e causare potenziali perdite di dati".

Mozilla avverte che se si utilizza una versione alpha di Lanikai, alcune estensioni potrebbero non funzionare con la nuova beta.
Fondato sul motore di rendering Gecko 1.9.2, lo stesso alla base di Firefox 3.6, Thunderbird 3.1 ha come principale obiettivo quello migliorare il processo di aggiornamento da Thunderbird 2, risolvere i vari problemi di gioventù del rinnovato client, affinarne le nuove funzionalità (questa beta si focalizza su completamento automatico, tab e gestore delle attività) e migliorarne stabilità, performance e gestione della memoria. L'elenco completo dei bug fix si trova qui.

Lanikai introduce anche una misura di sicurezza che impedisce il download di estensioni prive di firma digitale o provenienti da server sprovvisti del protocollo SHTTP.

In Thunderbird Beta 1 permangono alcuni problemi noti, quali l'incompatibilità con Kaspersky Anti-Spam Extension, un bug che può occasionalmente impedire l'invio automatico delle email scritte offline, e un altro bug che talvolta causa la sparizione dei pulsanti nell'interfaccia di creazione di una email in puro testo.

Mozilla Messaging conta di rilasciare la versione finale di Thunderbird 3.1 per giugno.

Mozilla e Firefox 3.6
Proprio ieri Mozilla ha annunciato che nei prossimi giorni gli utenti di Firefox che ancora non hanno aggiornato alla versione 3.6 riceveranno una notifica, sotto forma di finestra popup, che li inviterà a farlo. Naturalmente gli utenti saranno liberi di rifiutare o posticipare la proposta di aggiornamento.

Mozilla ha fatto sapere che nei primi 50 giorni dal suo rilascio Firefox 3.6 è stato scaricato oltre 100milioni di volte e che, attualmente, il 90% delle estensioni è compatibile con la nuova versione del browser.

Alessandro Del Rosso
14 Commenti alla Notizia Thunderbird 3.1 è in beta
Ordina
  • uso thunderbird e mi ci trovo benissimo. l'unico add-on che uso è quello che mi permette di avere un calendario per gli appuntamenti outlook-like (non ricordo il nome).

    Ho qualche mal di pancia in altri casi aziendali in alcuni casi di importazione/esportazione delle mail, per esempio:

    - un utente ha deciso di tornare ad Outlook. Non esistono strumenti gratuiti per l'esportazione diretta verso Outlook 2007 per esempio? la cosa più pratica è ricavare delle EML, importarle in O.Express (o programma analogo di MS) e importarle poi da outlook di office, che non so da quale versione non digerisce più gli EML (mime) e invece vuole il formato "MSG" (a quanto ho capito proprietario e umanamente "illeggibile").
    - non posso importare direttamente da un file di outlook se le due applicazioni sono installate sulal stessa macchina? Questo è triste se pensiamo "ok, io non installo office, uso openoffice e thunderbird e... come importo il mio archivio di outlook che mi ero salvato?"

    ora, non ci ho dedicato molto tempo a queste cose, e infatti ho messo i dovuti punti interrogativi (se qualcuno ne sa qualcosaSorride ). però sarebbe bello che Thunderbird permettesse import & export in modo più evoluto e funzionale. Sicuramente il bacino di utenze si incrementerebbe di non poco...
    non+autenticato
  • refuso (uffa la fretta):
    non posso importare direttamente da un file di outlook se le due applicazioni !NON! sono installate sulla stessa macchina?

    Chiedo scusaSorride
    non+autenticato
  • Vedi se qui trovi la soluzione:
    http://forum.mozillaitalia.org/index.php?topic=147...

    oppure iscriviti al forum e cerca (prima di chiedere). Quest'argomento è molto gettonato.
    non+autenticato
  • Già fatto, però fino a quando si tratta di OE nessun problema... i problemi sono quelli che ti ho detto su. Esistono dei software a pagamento, se è per questo, ma non ti sembra ridicolo?

    Sarebbe bello uno sviluppo interno a T.B. ... speriamo!
    non+autenticato
  • Bhè se gli sviluppatori dormono non è colpa loro come Tab Scope non era compatibile ,infatti ultimo riasaliva al Agosto 2009 ,uscita la 3.6 disabilitato pochi giorni dopo è uscita la versione compatibile ovverò la 0.3
    Quindi sono gli sviluppatori che devono darsi una mossa .
    non+autenticato
  • certo.. mi dò una mossa.
    paghi tu i giorni in cui mi devo assentare dal lavoro per fare lo sviluppo immediato dell'estensione?
    non+autenticato
  • allora non la fai se non sei in grado
  • - Scritto da: lellykelly
    > allora non la fai se non sei in grado

    Sono in grado ma non posso lavorarci a tempo pieno, prima dovrei lavorare per vivere se permetti, poi devo pensare alla famiglia e poi alle estensioni.
    Non sono un dipendente di Mozilla Corporation e non sono pagato per lavorare su un'estensione che è frutto solo della mia volontà, del mio tempo e della mia passione.
    Deve entrarvi questo nella testa prima di esprimere il vostro (lecito) parere. Altrimenti potete darvi da fare anche voi, il codice è libero e chiunque può contribuire.
    non+autenticato
  • - Scritto da: Sky
    > - Scritto da: lellykelly
    > > allora non la fai se non sei in grado

    > Sono in grado ma non posso lavorarci a tempo
    > pieno, prima dovrei lavorare per vivere se
    > permetti, poi devo pensare alla famiglia e poi
    > alle estensioni.

    Fai benissimo...
    Grazie

    Non dare retta ai troll.
    krane
    22544
  • Falsissimo!
    Le estensioni su Firefox 3.6 sono spesso e volentieri NON compatibili.
    Utilizzare la 3.5.2-8 è d'obbligo, non è una scelta voluta.
    Che ripulissero il sito degli addons da tante estensioni vecchissime,
    per firefox 2.0 che manco è più supportato e fanno confusione.
    Devono compilare e commentare le schede degli addons e scrivere il PESO (in KB) dell'estensione che si va a scaricare (grave mancanza).

    Poi il pannello degli addons in Firefox deve scrivere quante estensioni sono installate in quel momento, Google Chrome lo fa:
    Estensione -> Go Estensions!
    non+autenticato
  • E vorrei aggiungere: secondo voi Firefox non è diventato lento e pesante rispetto alle prime versioni?
    non+autenticato
  • - Scritto da: Zio
    > E vorrei aggiungere: secondo voi Firefox non è
    > diventato lento e pesante rispetto alle prime
    > versioni?

    Rispetto a firefox 2 sicuramente no. E' più snello e veloce. Rispetto alle prime vesioni di firefox 3 forse è più lento in avvio, ma più veloce nell'apertura delle pagine. Almeno questa è la mia sensazione. Comunque credo he poi la cosa più importante nell'uso sia la stabilità. Non sono quei 2 secondi in più in avvio che ti rovinano la vita... scusate, OT, trovo piuttosto ridicoli i benchmark che i vari produttori di browser esibiscono vantando che il loro browser ci impiega tot decimi di secondo in meno a renderizzare questo o quest'altro contenuto...chissenefrega? non sono mica le olimpiadi.
    non+autenticato
  • No no, non mi riferivo a nessun benchmark o misura particolare, semplicemente all'esperienza di utilizzo. Boh, sarà solo una mia impressione alloraOcchiolino
    non+autenticato
  • "Lanikai introduce anche una misura di sicurezza che impedisce il download di estensioni prive di firma digitale o provenienti da server sprovvisti del protocollo SHTTP"

    Veramente il protocollo usato e' l'HTTPS non l'S-HTTP (ovvero il suo rivale ormai in disuso).
    non+autenticato