Alfonso Maruccia

Mozilla cestina i plug-in NPAPI

Anche la fondazione del Panda Rosso si dice pronta a pensionare i componenti aggiuntivi per browser. Flash sopravvive, e le tecnologie DRM standard sono qui per restare

Roma - Anche Mozilla Firefox abbandonerà presto la tecnologia di plug-in nota come Netscape Plugin Application Programming Interface (NPAPI): c'è ancora un po' di tempo per lo switch-off, mentre per i componenti più popolari si studiano soluzioni alternative.

Chrome ha già da tempo chiuso la porta in via definitiva ai plug-in NPAPI, e Mozilla ha ora fissato la data finale per l'eliminazione del supporto alla tecnologia per il dicembre 2016. "I plugin sono fonte di problemi, crash e incidenti di sicurezza per gli utenti del Web", spiega la Fondazione, quindi è giusto che vengano abbandonati una volta per tutte.

E Adobe Flash, il plug-in con una presenza costante nelle cronache informatiche per i (tanti) incidenti di sicurezza di cui sopra? Flash Player può restare, dice Mozilla, perché è ancora una parte integrante dell'esperienza Web per molti utenti e continuerà quindi a essere supportato su Firefox anche dopo la fine del 2016.
La Fondazione spiega di essere al lavoro per migliorare il codice e le funzionalità del Player di Adobe, mentre per gli altri plug-in NPAPI ancora molto popolari come Unity e Java si preparano metodi di fruizione alternativi come - nel caso di Java - Java Web Start.

Mozilla sostiene che il Web "moderno" è in grado di fornire molte delle funzionalità avanzate che in passato necessitavano della presenza di plug-in esterni, anche se in realtà il Web moderno ha già adottato, come parte integrante degli standard ratificati dal W3C, un modello che prevede l'utilizzo di codice binario esterno per la fruizione di contenuti protetti dalle tecnologie DRM (EME+CDM). Tutto cambia, nulla è cambiato, se non le parole per dirlo.

Alfonso Maruccia
Notizie collegate
  • TecnologiaChrome liquida l'ultimo retaggio di NetscapeMountain View conferma la roadmap che porterà all'eliminazione (graduale ma inesorabile) del supporto ai plugin NPAPI dal suo browser. Con buona pace di chi ancora sfrutta la vecchia tecnologia, come Silverlight di Microsoft
  • TecnologiaFirefox 38 addizionato di DRMMozilla ha rilasciato la nuova versione stabile del browser Firefox, che ora include il supporto ai sistemi DRM per la fruizione dei contenuti audiovisivi protetti. Era inevitabile, dicono dalla fondazione
  • TecnologiaFlash, un lungo addioAmazon annuncia che non accetterà più banner multimediali vecchio stampo. YouTube è già passata ad HTML5. L'inizio della fine per la tecnologia Adobe?
19 Commenti alla Notizia Mozilla cestina i plug-in NPAPI
Ordina
  • Se abilito il plugin di flash mi dice che è obsoleto, nella pagine degli Add-On di Mozilla, mi dice che devi cliccare espressamente per abilitarlo, quindi non vedo cosa stiano facendo per migliorare flash .....

    Aspetta però ... io uso Debian, quindi ? Non è che stanno facendo le migliorie solo per windows 10 ? Che è strano poi eh, per chi si occupa di open source.


    A proposito, perché Iceweasel è compilato includendo gstreamer, e Firefox è invece connesso a quello vecchio che non funziona ?

    No perché se non posso usare H264 e non posso usare Flash , non posso di fatto usare Mozilla ... che è ancora strano poi per chi si occupa di open source.
    non+autenticato
  • - Scritto da: nome a caso
    > Se abilito il plugin di flash mi dice che è
    > obsoleto,
    Questo probabilmente perché hai installato una vecchia versone di Flash. Con la versione attuale di Flash, penso che Firefox non dovrebbe mostrarti quel messaggio.
    non+autenticato
  • - Scritto da: nome a caso
    > Se abilito il plugin di flash mi dice che è
    > obsoleto, nella pagine degli Add-On di Mozilla,
    > mi dice che devi cliccare espressamente per
    > abilitarlo, quindi non vedo cosa stiano facendo
    > per migliorare flash
    > .....

    Se usi Debian, lancia:
    update-flasplugin-nonfree --install

    Purtroppo l'aggiornamento di Flash è manuale.
    non+autenticato
  • - Scritto da: Qualcuno
    > - Scritto da: nome a caso
    > > Se abilito il plugin di flash mi dice che è
    > > obsoleto, nella pagine degli Add-On di Mozilla,
    > > mi dice che devi cliccare espressamente per
    > > abilitarlo, quindi non vedo cosa stiano facendo
    > > per migliorare flash
    > > .....
    >
    > Se usi Debian, lancia:
    > update-flasplugin-nonfree --install
    >
    > Purtroppo l'aggiornamento di Flash è manuale.

    Si, ok, sul mio sistema non c'era update-flashplugin-nonfree, nonostante flashplugin-nonfree fosse installato, però dopo un purge e install ho ritrovato anche lo script di update.

    Certo che la vita un po` più semplice (non dico tanto, solo un po`) quelli di Debian mai eh !
    non+autenticato
  • - Scritto da: nome a caso

    >
    > Certo che la vita un po` più semplice (non dico
    > tanto, solo un po`) quelli di Debian mai eh
    > !

    Piu' semplice di cosi'!
    Che cosa intendi per "semplice" tu?
  • - Scritto da: Qualcuno
    > - Scritto da: nome a caso
    > > Se abilito il plugin di flash mi dice che è
    > > obsoleto, nella pagine degli Add-On di Mozilla,
    > > mi dice che devi cliccare espressamente per
    > > abilitarlo, quindi non vedo cosa stiano facendo
    > > per migliorare flash
    > > .....
    >
    > Se usi Debian, lancia:
    > update-flasplugin-nonfree --install
    >
    > Purtroppo l'aggiornamento di Flash è manuale.


    PS : comunque resto su iceweasel che è compilato a 64 bit e include con gstreamer sia webm che h264 direttamente come formati video.

    Purtroppo le versioni compilate ufficiali di Mozilla per Linux sono studiate per funzionare alla meglio su quasi tutti i sistemi ma mai in modo ottimale, che è il solito problema dell'installare files binari (o closed come Skype) su Linux.
    non+autenticato
  • Io su Jessie sto utilizzando il pepperflash con freshplayer e funziona bene. E' anche semplicissimo da installare, è già nei repository di debianOcchiolino
    non+autenticato
  • Ci sono alternative valide a DownThemAll per firefox scritte in PPAPI?
    A quanto dice il creatore di questo download manager sembra impossibile fare un plugin simile con le nuove API, in quanto troppo limitate.
    non+autenticato
  • e la stessa domanda anche per adblock plus, flashgot, video download helper, flashblock, block images..

    edit: anzi solo per flashgot e videodownloadhelper perchè ho visto che gli altri ci sono anche per chrome!

    Inoltre qualche estensione per chrome simile a quelle:

    download master
    get them all
    image downloader
    block image


    secondo il mio modesto parere quelle simili a flashgot, downthemall e videodownloadhelper vanno migliorate un po', sono un po' acerbe ancora ma molto è stato fatto.
    -----------------------------------------------------------
    Modificato dall' autore il 10 ottobre 2015 01.57
    -----------------------------------------------------------
    user_
    1026
  • > e la stessa domanda anche per adblock plus,
    > flashgot, video download helper, flashblock,
    > block images..

    Stai confondendo addon e plugin. Sono i plugin ad essere (giustamente) deprecati, non gli addon.
    non+autenticato
  • MI stai dicendo che non riguarda downthemall, flashgot, video download helper ? Sei sicuro ? Hai letto quello che ha scritto il creatore di downthemall nel suo sito ?
    -----------------------------------------------------------
    Modificato dall' autore il 12 ottobre 2015 16.57
    -----------------------------------------------------------
    user_
    1026
  • "È così che muore la libertà: sotto scroscianti applausi." diceva una giovane ragazza.

    cavare vecchi "insicuri" plugin sembra cosa buona... poi pero' hanno infarcito l'html5 e i browser ,con gli scroscianti applausi del w3c e altre utenze, di strumenti "nativi" di tracking, di audiovideo farciti al DRM, di blob binari e altre meraviglie ancora da venire.... PfffA bocca storta
    non+autenticato
  • Beh... essendo disponibile il sorgente di firefox, nulla potrebbe vietare un fork che supporti ancora i vecchi plugin, a meno che, Mozilla Foundation metta i bastoni fra le ruote a questo tipo di idee (tipo rendere impossibile tali idee, mettendo controlli, dipendenze strane, ...)
    non+autenticato
  • - Scritto da: Antani
    > Beh... essendo disponibile il sorgente di
    > firefox, nulla potrebbe vietare un fork che
    > supporti ancora i vecchi plugin, a meno che,
    > Mozilla Foundation metta i bastoni fra le ruote a
    > questo tipo di idee (tipo rendere impossibile
    > tali idee, mettendo controlli, dipendenze strane,
    > ...)


    ti sembrera' strano, ma c'e' ancora qualcuno che e' capace di dire no, sfanculare mozzilla e passare ad altro browser, magari uno che non supporta i filmanti. e fanculo pure a youtube se necessario.
    non+autenticato
  • Leggila diversamente.

    Oggi le loro porcate le fanno in linguaggio standard, analizzabile e filtrabile. Prima ti ficcavano (e a voltr lo fanno ancora) del blobbone binario oscuro che faceva cose...
    non+autenticato
  • - Scritto da: Antani
    > Beh... essendo disponibile il sorgente di
    > firefox, nulla potrebbe vietare un fork che
    > supporti ancora i vecchi plugin, a meno che,
    > Mozilla Foundation metta i bastoni fra le ruote a
    > questo tipo di idee (tipo rendere impossibile
    > tali idee, mettendo controlli, dipendenze strane,
    > ...)
    e' un discorso lungo.. ma NON e' un buon modo di procedere... come i caproni che ridono ogni volta che AGCOM "censura" un sito cosidetto pirata... perche' "tanto la censura si bypassa".. ok, ma il punto e' con-dannare le leggi di merda coi privilegi temporali a 150 anni, NON bypassare quella censura in modo tecnico. idem in questo caso....

    Interessante questo draft, in proposito http://mnot.github.io/I-D/for-the-users/
    non+autenticato
  • - Scritto da: bubba
    > - Scritto da: Antani
    > > Beh... essendo disponibile il sorgente di
    > > firefox, nulla potrebbe vietare un fork che
    > > supporti ancora i vecchi plugin, a meno che,
    > > Mozilla Foundation metta i bastoni fra le ruote
    > a
    > > questo tipo di idee (tipo rendere impossibile
    > > tali idee, mettendo controlli, dipendenze
    > strane,
    > > ...)
    > e' un discorso lungo.. ma NON e' un buon modo di
    > procedere... come i caproni che ridono ogni volta
    > che AGCOM "censura" un sito cosidetto pirata...
    > perche' "tanto la censura si bypassa".. ok, ma il
    > punto e' con-dannare le leggi di merda coi
    > privilegi temporali a 150 anni, NON bypassare
    > quella censura in modo tecnico. idem in questo
    > caso....

    Si, ma il punto e' che io e te ci informiamo e veniamo a sapere che il tal sito e' stato oggetto di censura.
    Prendi mio cognato, non informatico, utente qualunque, che usa la rete per scaricae tutto quello che si trova in giro: manco si rende conto che il sito a cui si collega per i link dei files da scaricare e' stato oggetto di censura. Lui lo vede li', bello come il sole, clicca e scarica.


    > Interessante questo draft, in proposito
    > http://mnot.github.io/I-D/for-the-users/

    Come lo hai trovato?
  • > cavare vecchi "insicuri" plugin sembra cosa
    > buona... poi pero' hanno infarcito l'html5 e i
    > browser ,con gli scroscianti applausi del w3c e
    > altre utenze, di strumenti "nativi" di tracking,
    > di audiovideo farciti al DRM, di blob binari e
    > altre meraviglie ancora da venire.... Pfff
    >A bocca storta

    Non è una soluzione perfetta, ma è comunque meglio dello stato attuale delle cose. L'importante è che la situazione gradualmente migliori.
    non+autenticato
  • mi sa che prima della libertà morirà la sicurezza

    si parla tanto di quanto flash faccia schifo e quanto sia fighissimo html5

    poi però, ti accorgi che i ricercatori che scavano nei meandri di html5 di bug ne hanno trovati parecchi e pure più gravi di quelli di flash

    e stiamo parlando di una tecnologia ancora "poco" diffusa, per cui c'è poco incentivo per bucarla
    non+autenticato